본문내용 바로가기 메인메뉴 바로가기 푸터 바로가기

보안공지

OpenSSL 취약점 보안 업데이트 권고2022.05.19
□ 개요
 o OpenSSL에서 발생하는 취약점을 해결한 보안 업데이트 발표
 o 낮은 버전 사용자는 여러 가지 공격에 취약하므로, 최신 버전으로 업데이트 권고
 
□ 설명 [1]
 o OpenSSL 내 c_rehash 스크립트에서 쉘 메타 문자를 적절하게 삭제하지 않아 발생하는 명령 주입 취약점(CVE-2022-1292)
 o OpenSSL 내 OCSP_basic_verify 함수가 응답 서명 인증서를 잘못 확인하여 발생하는 인증 오류 취약점(CVE-2022-1343)
 o RC4-MD5 암호 제품군을 통해 구현된 OpenSSL에서 AAD 데이터를 MAC키로 잘못 사용하여 발생하는 비밀번호 오류 취약점(CVE-2022-1434)
 o OpenSSL에서 인증서 또는 키를 디코딩할 때 사용하는 OPENSSL_LH_flush() 함수의 메모리 재사용을 중단하는 버그로 인해 발생하는 서비스 거부 취약점(CVE-2022-1473)

□ 영향받는 버전
 o OpenSSL 1.0.2 및 이전 버전
 o OpenSSL 1.1.1 및 이전 버전
 o OpenSSL 3.0 및 이전 버전

□ 해결 방안
 o 해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이트 [2]
  - OpenSSL 1.0.2 버전 사용자 : 1.0.2ze 버전으로 업데이트
  - OpenSSL 1.1.1 버전 사용자 : 1.1.1o 버전으로 업데이트
  - OpenSSL 3.0 버전 사용자 : 3.0.3 버전으로 업데이트
 ※ OpenSSL 1.0.2 버전(Premium Level Support 사용자 제외) 및 1.1.0 버전은 더 이상 업데이트가 지원되지 않으니 OpenSSL 1.1.1o 또는 3.0.3 버전으로 변경할 것을 권고

□ 기타 문의사항
 o 한국인터넷진흥원 사이버민원센터: 국번없이 118
 
[참고사이트]
[1] https://www.openssl.org/news/secadv/20220503.txt
[2] https://www.openssl.org/source/


□ 작성 : 침해사고분석단 취약점분석팀
키워드 OpenSSL